Update auf Xorg 1.5

Gentoo-Blog Ersatz

Moderator: el_hakim

Antworten
Benutzeravatar
el_hakim
Beiträge: 1114
Registriert: 09.08.2007, 13:53
Kontaktdaten:

Update auf Xorg 1.5

Beitrag von el_hakim » 28.04.2009, 18:31

Seit einiger Zeit ist der 1.5er Xserver stable (Ausführliche Updateanleitung).

Die Kurzfassung:
  • Falls noch nicht geschehen, evdev zu den INPUT_DEVICES in der make.conf hinzufügen.
  • Checken ob Event interface im Kernel aktiviert ist (Device Drivers/Input Devices).
  • hal Use-Flag global setzen
  • jetzt das world-Update durchführen (und auch komplett durchlaufen lassen, nicht wahr losminkos?!)
  • hald dauerhaft starten:

    Code: Alles auswählen

    rc-update add hald default
  • in /etc/hal/fdi/policy eine Datei mit der Spracheinstellung für die Tastatur erstellen. Z.B. 10-xinput-kbd.fdi:

    Code: Alles auswählen

    <?xml version="1.0" encoding="UTF-8"?>
    <deviceinfo version="0.2">
       <match key="info.capabilities" contains="input.keyboard">
          <merge key="input.x11_options.XkbLayout" type="string">de</merge>
          <merge key="input.x11_options.XkbModel" type="string">pc105</merge>
       </match>
    </deviceinfo>
Jetzt kann noch die xorg.conf abgespeckt werden. Insbesondere alle Input-Devices können raus, da die ab jetzt zuverlässig vom hald gemanged werden. Ich habe noch Modelines, Monitor-Einstellungen, etc. entfernt, so dass meine xorg.conf jetzt erfreulich kurz ist:

Code: Alles auswählen

Section "Module"
    Load        "dbe"   # Double buffer extension
    Load        "type1"
    Load        "freetype"
    Load       "glx"
    Load       "extmod"
EndSection

Section "Files"
    FontPath   "/usr/share/fonts/misc/"
    FontPath   "/usr/share/fonts/TTF/"
    FontPath   "/usr/share/fonts/Type1/"
    FontPath   "/usr/share/fonts/75dpi/"
    FontPath   "/usr/share/fonts/100dpi/"
    FontPath   "/usr/share/fonts/local/"
EndSection

Section "Monitor"
    Identifier  "hansol"
EndSection

Section "Device"
    Identifier  "6600gt"
    Driver      "nvidia"
    Option "NoLogo"                     "true"
    Option "RenderAccel" "true"
    Option "AllowGLXWithcomposite" "true"
    Option "DisableGLXRootClipping" "true"
    Option "XAANoOffscreenPixmaps" "true" 
    Option "DRI"                   "true"
EndSection

Section "Screen"
    Identifier  "Screen 1"
    Device      "6600gt"
    Monitor     "hansol"
    DefaultDepth 24
    Option       "AddARGBGLXVisuals" "True"
EndSection

Section "ServerLayout"
    Identifier  "Simple Layout"
    Screen "Screen 1"
EndSection

Section "Extensions"
    Option "Composite" "Enable"
EndSection
Danach neu starten und (hoffentlich) über funktionierendes X freuen, :).

Falls das Tastaturlayout nicht stimmen sollte, mal schauen ob einen Xmodmap geladen wird. Das verträgt sich anscheinend nicht mehr mit dem neuen Xorg. Einfach rauswerfen. Wie man Sondertasten nutzt, dazu mache ich demnächst mal einen extra Post.
Ubuntu: African word meaning "Gentoo is to hard for me"

Antworten